#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s(?=(?:[^'"`]*(['"`])[^'"`]*\1)*[^'"`]*$)"
Local $sString = "Split on spaces, except "for this", and 'this section', and `ignore this too`."
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)