$re = '/\s(?=(?:[^\'"`]*([\'"`])[^\'"`]*\1)*[^\'"`]*$)/';
$str = 'Split on spaces, except "for this", and \'this section\', and `ignore this too`.';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;