use strict;
my $str = 'Split on spaces, except "for this", and \'this section\', and `ignore this too`.';
my $regex = qr/\s(?=(?:[^'"`]*(['"`])[^'"`]*\1)*[^'"`]*$)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";