re = /\s(?=(?:[^'"`]*(['"`])[^'"`]*\1)*[^'"`]*$)/
str = 'Split on spaces, except "for this", and \'this section\', and `ignore this too`.'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result