using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[-+]?\d+(?:\.\d+)?(?: [-+]?\d+(?:\.\d+)?)*$";
string input = @"15 35 -45 8 -2.3 4564.18 56
12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}