package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[-+]?\d+(?:\.\d+)?(?: [-+]?\d+(?:\.\d+)?)*$`)
var str = `15 35 -45 8 -2.3 4564.18 56
12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}