using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>.*?href=""(.*?)""";
string input = @"<a href=""/wiki/Computer_scientist"" title=""Computer scientist"">computer scientist</a>
<p>Its fields can be divided into a variety of theoretical and <a href=""/wiki/Practical_disciplines""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}