const regex = /<p>.*?href="(.*?)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>.*?href="(.*?)"', 'g')
const str = `<a href="/wiki/Computer_scientist" title="Computer scientist">computer scientist</a>
<p>Its fields can be divided into a variety of theoretical and <a href="/wiki/Practical_disciplines"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}