import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<p>.*?href=\"(.*?)\"";
final String string = "<a href=\"/wiki/Computer_scientist\" title=\"Computer scientist\">computer scientist</a> \n"
+ "<p>Its fields can be divided into a variety of theoretical and <a href=\"/wiki/Practical_disciplines\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}