$re = '/<p>.*?href="(.*?)"/';
$str = '<a href="/wiki/Computer_scientist" title="Computer scientist">computer scientist</a>
<p>Its fields can be divided into a variety of theoretical and <a href="/wiki/Practical_disciplines"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);