#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iumU)(?:controllers?\\[^\\])?(?:[^\\\n]+)controller$"
Local $sString = "App\Controller\FooBar\BazController" & @CRLF & _
"App\Controller\BazController" & @CRLF & _
"App\FooController" & @CRLF & _
"App\Controller" & @CRLF & _
"App\Controllers\FooBar\BazController" & @CRLF & _
"App\Controllers\BazController" & @CRLF & _
"App\Controllers\None" & @CRLF & _
"App\BaseController\NestedControllers\Foo\Bar\LastController" & @CRLF & _
"App\None" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")