re = /(?:controllers?\\[^\\])?(?:[^\\\n]+)controller$/im
str = 'App\\Controller\\FooBar\\BazController
App\\Controller\\BazController
App\\FooController
App\\Controller
App\\Controllers\\FooBar\\BazController
App\\Controllers\\BazController
App\\Controllers\\None
App\\BaseController\\NestedControllers\\Foo\\Bar\\LastController
App\\None
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end