const regex = new RegExp('(?:controllers?\\\\[^\\\\])?(?:[^\\\\\\n]+)controller$', 'gium')
const str = `App\\Controller\\FooBar\\BazController
App\\Controller\\BazController
App\\FooController
App\\Controller
App\\Controllers\\FooBar\\BazController
App\\Controllers\\BazController
App\\Controllers\\None
App\\BaseController\\NestedControllers\\Foo\\Bar\\LastController
App\\None
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}