$re = '~(?:controllers?\\\\[^\\\\])?(?:[^\\\\\n]+)controller$~iumU';
$str = 'App\\Controller\\FooBar\\BazController
App\\Controller\\BazController
App\\FooController
App\\Controller
App\\Controllers\\FooBar\\BazController
App\\Controllers\\BazController
App\\Controllers\\None
App\\BaseController\\NestedControllers\\Foo\\Bar\\LastController
App\\None
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);