#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:[^À-ú]|^)\b(MyString)\b(?:[^À-ú]|$)"
Local $sString = "MyString" & @CRLF & _
"Lorem ipsum. MyString dolor sit amet" & @CRLF & _
"(MyString)" & @CRLF & _
"MyString" & @CRLF & _
"" & @CRLF & _
"BetweenCharactersMyStringIsNotFound" & @CRLF & _
"éMyStringé" & @CRLF & _
"ùMyString" & @CRLF & _
"MyStringÖ" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")