using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^À-ú]|^)\b(MyString)\b(?:[^À-ú]|$)";
string input = @"MyString
Lorem ipsum. MyString dolor sit amet
(MyString)
MyString
BetweenCharactersMyStringIsNotFound
éMyStringé
ùMyString
MyStringÖ
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}