import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^À-ú]|^)\\b(MyString)\\b(?:[^À-ú]|$)";
final String string = "MyString\n"
+ "Lorem ipsum. MyString dolor sit amet\n"
+ "(MyString)\n"
+ "MyString\n\n"
+ "BetweenCharactersMyStringIsNotFound\n"
+ "éMyStringé\n"
+ "ùMyString\n"
+ "MyStringÖ\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}