package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?J)(?:^|[\r\n])\|(?:(?<MyField>a)\|b\|)|(?:c\|(?<MyField>b)\|)`)
var str = `|a|b| ---> should pick out 'a' only
|c|b| ---> should pick out 'b' only`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}