import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?J)(?:^|[\\r\\n])\\|(?:(?<MyField>a)\\|b\\|)|(?:c\\|(?<MyField>b)\\|)";
final String string = "|a|b| ---> should pick out 'a' only\n"
+ "|c|b| ---> should pick out 'b' only";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}