re = /(?J)(?:^|[\r\n])\|(?:(?<MyField>a)\|b\|)|(?:c\|(?<MyField>b)\|)/m
str = '|a|b| ---> should pick out \'a\' only
|c|b| ---> should pick out \'b\' only'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end