$re = '/(?J)(?:^|[\r\n])\|(?:(?<MyField>a)\|b\|)|(?:c\|(?<MyField>b)\|)/m';
$str = '|a|b| ---> should pick out \'a\' only
|c|b| ---> should pick out \'b\' only';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);