import re
regex = re.compile(r"^(?:(?<caml>\w+(?:\-\w+)+)|\[(?<with>[a-z\d-]+)(?<qualify>.+)\]|\[{1,2}\.{3}(?<all>[\w\-]+)\]{1,2}|\((?<group>[\w\-]+)\)|(?<reserved>[@_][\w\-]+)|(?<same>\.)|(?:(?<subpath>(?:(?:[\/\\][^\/\\]+)+[\/\\])|[\/\\])(?<nested>[^\\\/]+)))$", flags=re.MULTILINE)
test_str = "this_is-hyphened"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")