re = /^(?:(?<caml>\w+(?:\-\w+)+)|\[(?<with>[a-z\d-]+)(?<qualify>.+)\]|\[{1,2}\.{3}(?<all>[\w\-]+)\]{1,2}|\((?<group>[\w\-]+)\)|(?<reserved>[@_][\w\-]+)|(?<same>\.)|(?:(?<subpath>(?:(?:[\/\\][^\/\\]+)+[\/\\])|[\/\\])(?<nested>[^\\\/]+)))$/m
str = 'this_is-hyphened'
# Print the match result
str.match(re) do |match|
puts match.to_s
end