// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?<caml>\w+(?:\-\w+)+)|\[(?<with>[a-z\d-]+)(?<qualify>.+)\]|\[{1,2}\.{3}(?<all>[\w\-]+)\]{1,2}|\((?<group>[\w\-]+)\)|(?<reserved>[@_][\w\-]+)|(?<same>\.)|(?:(?<subpath>(?:(?:[\/\\][^\/\\]+)+[\/\\])|[\/\\])(?<nested>[^\\\/]+)))$").unwrap();
let string = "this_is-hyphened";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}