use strict;
my $str = 'someCode() // someComment
';
my $regex = qr@^(.*)//(.*)@mp;
my $subst = '//$2\\n$1';
my $result = $str =~ s@$regex@$subst@rg;
print "The result of the substitution is' $result\n";