re = /^(.*)\/\/(.*)/m
str = 'someCode() // someComment
'
subst = '//$2\\n$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result