$re = '@^(.*)//(.*)@m';
$str = 'someCode() // someComment
';
$subst = "//$2\n$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;