import Foundation
let pattern = #"^(.*)//(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
someCode() // someComment
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"//$2\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)