import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)\\$?(?:\\d{1,3}(?:\\,\\d{3})*)?\\.\\d{2}-?(?!\\S)";
final String string = "Transfer to Retirement Rsvs-MA FX .11 \n"
+ "Opening Balance FX 342,536,002.63 \n"
+ "VA 85.85 \n"
+ "VB .00 \n"
+ "Manual Adjustment FX 6,838.36-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}