const regex = new RegExp('(?<!\\S)\\$?(?:\\d{1,3}(?:\\,\\d{3})*)?\\.\\d{2}-?(?!\\S)', 'gm')
const str = `Transfer to Retirement Rsvs-MA FX .11
Opening Balance FX 342,536,002.63
VA 85.85
VB .00
Manual Adjustment FX 6,838.36-`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}