re = /(?<!\S)\$?(?:\d{1,3}(?:\,\d{3})*)?\.\d{2}-?(?!\S)/m
str = 'Transfer to Retirement Rsvs-MA FX .11
Opening Balance FX 342,536,002.63
VA 85.85
VB .00
Manual Adjustment FX 6,838.36-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end