import re
regex = re.compile(r"(?<!\S)\$?(?:\d{1,3}(?:\,\d{3})*)?\.\d{2}-?(?!\S)", flags=re.MULTILINE)
test_str = ("Transfer to Retirement Rsvs-MA FX .11 \n"
"Opening Balance FX 342,536,002.63 \n"
"VA 85.85 \n"
"VB .00 \n"
"Manual Adjustment FX 6,838.36-")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")