const regex = /(?:utm_source|utm_campaign|pkwid|ep_mid|et_mid|ep_rid)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:utm_source|utm_campaign|pkwid|ep_mid|et_mid|ep_rid)', 'gmi')
const str = `https://stackoverflow.com/questions/74376327/?pkwid=12&utm_source=home`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}