$re = '/(?:utm_source|utm_campaign|pkwid|ep_mid|et_mid|ep_rid)/mi';
$str = 'https://stackoverflow.com/questions/74376327/?pkwid=12&utm_source=home';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);