// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:utm_source|utm_campaign|pkwid|ep_mid|et_mid|ep_rid)").unwrap();
let string = "https://stackoverflow.com/questions/74376327/?pkwid=12&utm_source=home";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}