re = /(?:utm_source|utm_campaign|pkwid|ep_mid|et_mid|ep_rid)/mi
str = 'https://stackoverflow.com/questions/74376327/?pkwid=12&utm_source=home'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end