package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((?:\{.*?\}|[^|])+)\|`)
var str = `UTM_Source:google|UTM_Medium:cpc|UTM_Campaign:{Core|IN|Desktop|BMM|Top Cities|TS}| UTM_Content:{Compare Car Insurance}|UTM_Term
`
var substitution = "$1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}