use strict;
my $str = 'UTM_Source:google|UTM_Medium:cpc|UTM_Campaign:{Core|IN|Desktop|BMM|Top Cities|TS}| UTM_Content:{Compare Car Insurance}|UTM_Term
';
my $regex = qr/((?:\{.*?\}|[^|])+)\|/mp;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";