re = /((?:\{.*?\}|[^|])+)\|/m
str = 'UTM_Source:google|UTM_Medium:cpc|UTM_Campaign:{Core|IN|Desktop|BMM|Top Cities|TS}| UTM_Content:{Compare Car Insurance}|UTM_Term
'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result