// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:\{.*?\}|[^|])+)\|").unwrap();
let string = "UTM_Source:google|UTM_Medium:cpc|UTM_Campaign:{Core|IN|Desktop|BMM|Top Cities|TS}| UTM_Content:{Compare Car Insurance}|UTM_Term
";
let substitution = "$1 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}