using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"USB\\VID_.+?&PID_.+?\\.+?\s+\:\s+(.+?)$";
string input = @"USB\VID_05B8&PID_3143\5&95B63F&0&2 : USB-Eingabegerät";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}