$re = '/USB\\\\VID_.+?&PID_.+?\\\\.+?\s+\:\s+(.+?)$/m';
$str = 'USB\\VID_05B8&PID_3143\\5&95B63F&0&2 : USB-Eingabegerät';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);