import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "USB\\\\VID_.+?&PID_.+?\\\\.+?\\s+\\:\\s+(.+?)$";
final String string = "USB\\VID_05B8&PID_3143\\5&95B63F&0&2 : USB-Eingabegerät";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}