// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)USB\\VID_.+?&PID_.+?\\.+?\s+\:\s+(.+?)$").unwrap();
let string = "USB\\VID_05B8&PID_3143\\5&95B63F&0&2 : USB-Eingabegerät";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}