use strict;
my $str = 'SELECT Name AS [Object Name], Switch([Type]=5,\'Query\',[Type]=-32768,\'Form\',[Type]=6,\'Table\') AS [Object Type], Switch([Type]=5,1,[Type]=-32768,2,[Type] In (1,4,6),6) AS [Object Type ID], Left(Name,4) as Prefix, LTrim(RTrim(Mid([Name],5,30))) as Suffix
SELECT "Amy\'s code is righteous.", left("abc",1), right(\'source code\',4), "Bill\'s code has been righteous too."
----------
End goal is to replace all commas in SQL SELECT clause with comma+linefeed but ignore commas inside parenthesis (which may be nested).
\\((?:[^()]++|(?R))*\\)
This expression will find all of the nested parentheis using recursion. I want to do one of these two options:
a) Replace all commas in the matched groups with the pipe "|" character,
then with two simple StrReplace() calls: replace all commas with comma+linefeed, then replace all | with comma.
OR
b) Select all text that is not in the matched group and replace commas with comma+linefeed.
I\'m using AutoHotkey and the RegExReplace() function.';
my $regex = qr/\((?:[^()]++|(?R))*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}