using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\(?\+?([0-9]{1,3})?[- (]?\(?([0-9]{3})?[-. )]*?\(?([0-9]{3})[-. )]*?\(?([0-9]{4})\)?\s?$";
string input = @"+1 210.867.5309
(210) 867 5309
867-5309
210-867-5309";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}