package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(?\+?([0-9]{1,3})?[- (]?\(?([0-9]{3})?[-. )]*?\(?([0-9]{3})[-. )]*?\(?([0-9]{4})\)?\s?$`)
var str = `+1 210.867.5309
(210) 867 5309
867-5309
210-867-5309`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}