re = /^\(?\+?([0-9]{1,3})?[- (]?\(?([0-9]{3})?[-. )]*?\(?([0-9]{3})[-. )]*?\(?([0-9]{4})\)?\s?$/m
str = '+1 210.867.5309
(210) 867 5309
867-5309
210-867-5309'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end