#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{11}|\d{3}-\d{8})"
Local $sString = "222-22222222" & @CRLF & _
"22222222222" & @CRLF & _
"22222" & @CRLF & _
"222224452=222" & @CRLF & _
"223-22222222" & @CRLF & _
"11111111111" & @CRLF & _
"SAAAAAAAAAA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")