// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{11}|\d{3}-\d{8})").unwrap();
let string = "222-22222222
22222222222
22222
222224452=222
223-22222222
11111111111
SAAAAAAAAAA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}